Как не допустить 10 фатальных ошибок при работе с Linux Mint, Ubuntu и Fedora Workstation

Существуют 10 ошибок, которых вы наверняка желаете избежать, сохранив тем самым работоспособность своей системы. Ведь эти ошибки могут оказаться фатальными для любой системы.

Как и в случае любых предупреждений, приведенные ниже предупреждения особенно важны для начинающих пользователей Linux. Опытные пользователи Linux не допускают подобных ошибок и даже не находятся в группе риска. А в том случае, если они по каким-либо причинам все же допускают ошибки, они способны самостоятельно исправить их…

Давайте рассмотрим пример с самолетами: все зависит от того, каким образом вы желаете использовать ваш компьютер.

Как пилот проверенного временем истребителя F-18.

F18

Как пилот экспериментального самолета.

Proefmodel

Или как пилот… непонятного летательного аппарата.

Fubar

Если вам (на данный момент) важнее всего проверенная в боях надежность истребителя F-18, приведенные ниже предупреждения будут полезны для вас.

Основные предупреждения

1. Будьте особенно осторожны с внешними репозиториями пакетов ПО (такими, как PPA и COPR) и с неофициальными файлами пакетов ПО с расширениями .deb и .rpm

Программное обеспечение из персональных репозиториев ПО (PPA в Linux Mint и Ubuntu и COPR в Fedora Workstation) в большинстве своем не тестируется на работоспособность в вашей версии дистрибутива и может негативно повлиять на стабильность, надежность и безопасность вашей системы.

Более того, при использовании подобного программного обеспечения вы попадете в зависимость от владельца персонального репозитория ПО, а это обычно один неизвестный человек. В принципе, после добавления адреса персонального репозитория в список источников программного обеспечения вашей ситемы, вы предоставляете этому человеку полный контроль над ней.

Исходя из этого, следует использовать персональные репозитории лишь тогда (и только тогда), когда у вас нет реальных альтернатив. Или же в тогда, когда вы тестируете определенное программное обеспечение (вы должны заниматься этим лишь на компьютере, который не используется для выполнения важной работы).

Программное обеспечение из персональных репозиториев вызывает, мягко говоря, смешанные чувства. При разумном и добросовестном использовании оно может сослужить вам отличную службу. Но при его беспорядочной установке можно запросто нарушить работу системы.

В вашей системе уже используется множество персональных репозиториев, которые вы желаете отключить? В таком случае вы можете пересоздать файл списка источников программного обеспечения следующим образом.

Также следует быть особенно осторожным с неофициальными файлами пакетов программного обеспечения с расширениями .deb и .rpm.

Файлы пакетов программного обеспечения с расширениями .deb и .rpm являются отдельными установщиками программного обеспечения, примерно такими же, как файлы установщиков с расширением .msi в ОС Windows. Вы можете загрузить файлы пакетов формата DEB и RPM с некоторых веб-сайтов. При использовании двойного клика по отношению к такому файлу пакета вам будет предложено ввести пароль, после чего программное обеспечение из него будет установлено в вашу систему.

Устанавливайте программное обеспечение лишь из тех файлов пакетов формата DEB или RPM, которым вы полностью доверяете. Если вы не уверены насчет источника файла пакета, откажитесь от установки программного обеспечения из него! Данные файлы никак не подписываются, не проверяются и могут нарушить работоспособность вашей системы. Они могут содержать даже вредоносное программное обеспечение, такое, как программное обеспечение, осуществляющее слежку, и другое подобное программное обеспечение.

Описанные случаи имели место: я слышал как минимум об одном инциденте. Несколько лет назад вредоносное программное обеспечение (троян) было обнаружено в файле пакета программного обеспечения формата DEB, который распространялся через популярный веб-сайт gnome-look.org.

2. Используйте утилиты sudo и gksudo только тогда, когда это действительно необходимо

Утилиты sudo и gksudo позволяют вам поднять собственные права в системе до прав пользователя root (прав администратора). Вы должны использовать их лишь при запуске приложений для администрирования системы и никогда не использовать для запуска обычных приложений.

Необоснованное использование утилиты sudo (и gksudo) может привести к установке некорректных прав доступа к файлам и директориям, что в свою очередь приведет к различным сложно диагностируемым системным неполадкам.

При запуске обычного приложения с помощью утилиты sudo (или gksudo) оно будет создавать файлы и директории в домашней директории пользователя root, а не в вашей домашней директории. К тому же, оно может сделать пользователя root владельцем некоторых уже существующих файлов.

Никогда не запускайте обычные приложения с помощью утилит sudo (или gksudo). Это попросту не нужно, опасно и с большой вероятностью приведет к изменению прав доступа к вашим собственным файлам.

3. Проявляйте осторожность при установке дополнений, расширений, апплетов и десклетов

Проявляйте особую осторожность при установке любых дополнений, расширений, апплетов и десклетов. Некоторые из них могут могут стать причиной серьезных проблем.

3.1. Дополнения и расширения для веб-браузеров Firefox и Chromium: не стоит слепо доверять им

Под видом дополнений для веб-браузера Firefox может распространяться вредоносное программное обеспечение; подобные инциденты уже были, несмотря на все меры, принимаемые компанией Mozilla для его выявления. Не стоит слепо доверять даже дополнениям с официального сайта. Это же утверждение справедливо и для расширений веб-браузеров Chrome/Chromium.

Также следует по возможности минимизировать количество установленных дополнений и расширений веб-браузера: не стоит превращать веб-браузер Firefox или Chrome/Chromium в рождественскую елку. Чем больше дополнений вы установите, тем медленнее будет работать ваш веб-браузер. Более того, некоторые дополнения могут оказаться причиной некорректной работы других дополнений или даже самого веб-браузера.

Вы уже пострадали от подобного дополнения? В этом случае вы можете удалить директорию с данными вашего веб-браузера таким образом, как описано в данном документе (в разделе 8).

3.2. Десклеты и апплеты и расширения GNOME Shell: думайте перед их установкой

Апплеты, десклеты и расширения GNOME Shell могут украсить ваш рабочий стол и даже позволят вам пользоваться полезными функциями. Но каждый из них может стать причиной различных проблем. Поэтому постарайтесь минимизировать их количество.

Чем больше десклетов, апплетов и расширений вы установите, тем медленнее будет работать ваша система. При этом некоторые из них могут конфликтовать друг с другом.

4. Никогда не используйте приложения для очистки системы или дефрагментации файловых систем

Воспользовавшись приложениями для очистки системы, такими, как Bleachbit или deborphan, вы можете удалить гораздо больше необходимых файлов, чем предполагаете. Не стоит доверять подобным приложениям, так как каждое из них не является идеальным и зачастую удаляет необходимые для корректного функционирования системы файлы, выводя ее из строя.

Кроме того, они попросту не нужны. В Linux создается не так много ненужных файлов. Именно поэтому очистка системы обычно не дает каких-либо ощутимых преимуществ. В самом лучшем случае вы сможете добиться освобождения около гигабайта дискового пространства, рискуя удалить важные данные. Если вы все же желаете безопасно очистить систему, воспользуйтесь соответствующими инструкциями для дистрибутивов Linux Mint, Ubuntu и Fedora Workstation.

Инструменты для дефрагментации файловых систем таят в себе еще большую угрозу. К сожалению, вы все еще можете обнаружить несколько таких инструментов «на обочине» экосистемы Linux… Ни в коем случае не используйте их! Ведь в случае их использования велика вероятность либо повреждения файловой системы без возможности последующего восстановления, либо необратимой потери большого количества файлов.

Инструменты для дефрагментации файловых систем являются очень опасными и по сути не нужными утилитами. Это относится ко всем подобным инструментам без исключений. Следует упомянуть и о том, что используемые в Linux файловые системы вообще не нуждаются в дефрагментации.

5. Не смешивайте компоненты окружения рабочего стола KDE с компонентами других рабочих столов

В Linux Mint, Ubuntu и Fedora Workstation вы можете установить окружение рабочего стола KDE рядом с уже установленным окружением рабочего стола (таким, как Mate, Cinnamon, Unity, Xfce, LXDE или GNOME), безнадежно смешав компоненты обоих окружений рабочих столов. В результате этого резко упадет производительность и стабильность работы вашей системы.

Если вы желаете, чтобы в будущем ваша система корректно функционировала, пользуйтесь лишь окружением рабочего стола, поставляемым в ее составе по умолчанию. Попытайтесь вообще не устанавливать приложения из состава окружения рабочего стола KDE в Linux Mint, Ubuntu или Fedora Workstation, так как при установке любого такого приложения (например, приложения для записи оптических дисков K3B) в качестве его зависимостей в вашу систему будет установлена практически половина компонентов окружения рабочего стола KDE.

Совет: в случае использования менеджера пакетов Synaptic Linux в Mint или Ubuntu или Yum Extender DNF в Fedora Workstation для установки приложений вы можете ознакомиться со списком зависимостей того или иного приложения перед его установкой.

Существуют окружения рабочего стола, которые используют множество низкоуровневых компонентов других окружений рабочего стола; эти окружения рабочего стола могут относительно безопасно устанавливаться друг рядом с другом. Например, Xfce (окружение рабочего стола дистрибутива Xubuntu) полностью совместимо с окружениями рабочего стола GNOME, Unity, а также Cinnamon и Mate, поставляемыми в дистрибутиве Linux Mint.

Но даже при установке нескольких из упомянутых выше окружений рабочего стола в вашу систему будут устанавливаться избыточные программные компоненты… Система с единственным окружением рабочего стола всегда будет более производительной.

Вы допустили ошибку, установив дополнительное окружение рабочего стола, и желаете исправить ее? К сожалению, в данном случае единственным решением является полная переустановка дистрибутива.

5.1. Не устанавливайте дополнительный полнофункциональный файловый менеджер

Развивая мысль о нежелательности установки нескольких окружений рабочего стола, несложно прийти к выводу о том, что также не следует устанавливать несколько полнофункциональных файловых менеджеров. Гораздо лучше использовать файловый менеджер, который поставляется по умолчанию вместе с окружением рабочего стола вашего дистрибутива.

Это объясняется тем, что полнофункциональные файловые менеджеры тесно связаны с окружениями рабочих столов, для которых они проектировались. Исходя из этого, они могут превратиться в источник проблем после установки в «чужом» окружении рабочего стола: обычно они пытаются максимально тесно интегрироваться с этим «чужим» окружением рабочего стола и иногда конфликтуют с основным файловым менеджером.

Исключением из данного правила являются независимые простые файловые менеджеры, такие, как GNOME Commander и Midnight Commander. Они никак не связаны с окружениями рабочего стола и выполняют лишь свою основную задачу: позволяют работать с файлами.

6. Никогда не используйте установочные сценарии для Linux Mint и Ubuntu, такие, как Ultamatix, Ubuntu Tweak, Ubuntu Sources List Generator или Ubuntuzilla

Использование всех без исключения сторонних установочных сценариев связано с различными опасностями: некоторые из них особо опасны, другие — менее опасны. Лучшим вариантом является полный отказ от их использования. Ниже я опишу некоторые из наиболее опасных сценариев.

6.1. Высокий уровень опасности: Ultamatix

Ultamatix является самым опасным из сценариев. Он может нанести непоправимый вред вашей системе.

Примечание: данный проект, скорее всего, более не развивается, но в прошлом он несколько раз восставал из мертвых… Именно поэтому я не удаляю данное предупреждение.

Ultamatix позволяет установить различные нестабильные версии приложений (ночные сборки). Кроме того, в данном сценарии используются параметры для принудительной установки пакетов программного обеспечения --assume-yes и --force-yes, которые крайне опасно использовать. Разработчик заявляет, что данные параметры используются потому, что «он не хочет утруждать пользователей ответами на различные вопросы». Ввиду этого достаточно лишь одной некорректной зависимости, некорректно работающего приложения или какой-либо другой недоработки для того, чтобы нарушить работу вашей системы без возможности последующего восстановления…

Если вы уже пользовались данным сценарием, единственным вариантом очистки системы является ее полная переустановка. В этом случае также придется отформатировать корневой раздел.

Кроме того, сценарий Ultamatix в большинстве случаев просто не нужен: все, что он делает, может быть также сделано относительно безопасно с помощью официальных инструментов. Вам потребуется лишь приложить немного дополнительных усилий.

6.2. Средний уровень опасности: Ubuntu Tweak и Ubuntu Sources List Generator и GRUB Customizer

Приложения Ubuntu Tweak и Ubuntu Sources List Generator также опасны. Не используйте их! Они позволяют активировать некоторые персональные репозитории пакетов (PPA) со сторонним программным обеспечением без вывода информации об активированном источнике программного обеспечения и подтверждения корректности его цифровой подписи.

Таким образом, вы получите возможность установки всех пакетов программного обеспечения из этих персональных репозиториев пакетов без проверки их качества и получения информации об их совместимости с вашей версией дистрибутива или вашим аппаратным обеспечением. Да, это очень рискованно. Лучше держаться подальше от этих приложений…

6.3. Уровень опасности ниже среднего: Ubuntuzilla

Область действия сценария Ubuntuzilla значительно ограничена, а сам сценарий не связан с каким-либо рисками в плане безопасности функционирования системы. Но все таки лучше избегать его использования. Например, при установке Firefox с помощью Ubuntuzilla используется оригинальная версия от производителя, которая не полностью адаптирована к работе в дистрибутиве Linux Mint или Ubuntu, поэтому веб-браузер может работать не так, как вы ожидаете.

При использовании Ubuntuzilla вы обходите стороной большое количество оптимизаций и проверок качества веб-браузера Firefox, выполняемых разработчиками дистрибутива Ubuntu… Разумеется, это может негативно отразиться на стабильности и надежности Firefox.

7. Не активируйте репозиторий тестовых версий программного обеспечения «proposed» в Ubuntu, «romeo» в Linux Mint и «rawhide» в Fedora Workstation

Не активируйте репозиторий тестовых версий программного обеспечения «proposed» дистрибутива Ubuntu, если вы не тестируете новые версии программного обеспечения и дорожите стабильностью своей системы. В Linux Mint аналогичный репозиторий программного обеспечения носит имя «romeo», а в Fedora Workstation - «rawhide».

Источник приложений «proposed» в Ubuntu, «romeo» в Linux Mint или «rawhide» в Fedora Workstation предоставляет угрозу стабильности вашей системы. Он содержит нестабильное и в некоторых случаях некорректно работающее программное обеспечение, которое недостаточно отлажено и протестировано. Держитесь подальше от него!

Если вы активируете один из указанных источников приложений в вашей системе, ее стабильность рано или поздно значительно понизится. Единственным решением в таком случае является ее полная переустановка. При переустановке не стоит забывать о необходимости форматирования корневого раздела.

По умолчанию данные репозитории, разумеется, деактивированы, но на всякий случай рекомендуется проверить, деактивирован ли соотвествующий репозиторий в вашей системе.

Linux Mint: необходимо осуществить переход в рамках главного меню: «Меню — Администрирование — Менеджер обновлений». После этого в рамках меню открывшегося окна менеджера обновлений следует осуществить переход: «Правка — Источники приложений». Теперь следует нажать на кнопку «Официальные репозитории» в левой части окна и убедиться в том, что флажок «Нестабильные пакеты (romeo)» не установлен.

Ubuntu: если вы пока не установили менеджер пакетов программного обеспечения Synaptic, сейчас самый подходящий момент для того, чтобы сделать это. Synaptic предустановлен по умолчанию в Linux Mint, но отсутствует в Ubuntu. Поэтому воспользуйтесь центром приложений Ubuntu для установки менеджера пакетов Synaptic. После этого вы должны запустить Synaptic, нажав на логотип Ubuntu в левом верхнем углу экрана, введя запрос «synaptic» и выбрав пункт «Менеджер пакетов Synaptic». В рамках меню менеджер пакетов Sysnaptic следует осуществить переход «Настройки — Репозитории», перейти на вкладку «Обновления» в открывшемся окне и убедиться в том, что флажок «Обновления, не вошедшие в официальный выпуск (trusty-proposed)» не установлен.

Fedora Workstation: если вы пока не установили менеджер пакетов программного обеспечения Yum Extender DNF, сейчас самый подходящий момент для того, чтобы сделать это. Он не установлен по умолчанию, поэтому вам придется воспользоваться Центром приложений для его установки. После этого вы должны запустить Yum Extender DNF, перейдя в режим обзора, введя запрос «yum» и выбрав пункт «Yum Extender (DNF)». В рамках меню открываеющегося с помощью кнопки с шестеренкой в заголовке окна менеджера пакетов следует выбрать пункт «Preferences», перейти на вкладку «Repositories» в открывшемся окне и убедиться в отсутствии в списке репозиториев с суффиксом «rawhide».

Как неоднократного говорилось ранее: обязательно убедитесь в том, что репозиторий тестовых версий программного обеспечения не активирован в вашей системе.

Единственной причиной существования репозитория «romeo» (в Linux Mint), «trusty-proposed» (в Ubuntu) и «rawhide» в Fedora Workstation являются востребованность данного репозитория людьми, осуществляющими тестирование программного обеспечения. Эти люди помогают находить ошибки в обновлениях программного обеспечения перед тем, как эти обновления распространяются среди обычных пользователей дистрибутивов.

8. Обращайтесь с особой осторожностью с репозиториями программного обеспечения «Backports», «Partners» и «Independent» в Linux Mint и Ubuntu

В Linux Mint и Ubuntu существуют три репозитория программного обеспечения, которые могут быть относительно безопасно активированы в вашей системе, но при работе с которыми нужно проявлять максимальную осторожность: «Backports», «Partners» и «Independent».

По сути, активация данных репозиториев не является фатальной ошибкой, так как она связана лишь с допустимыми незначительными рисками. Однако, данные риски, хотя и являются допустимыми и незначительными, все же заслуживают внимания…

8.1. Репозиторий «Backports»

В дистрибутиве Linux Mint репозиторий портированных пакетов «backport» по умолчанию деактивирован, при этом лучше не активировать его самостоятельно.

В дистрибутиве Ubuntu, однако, репозиторий официально не поддерживаемых пакетов «backports» активирован по умолчанию. При этом для данного репозитория установлен пониженный (безопасный) приоритет, благодаря которому вы сможете устанавливать программное обеспечение из него лишь тогда, когда явно укажете на него.
По аналогии с предыдущим разделом, вы можете проверить, активирован ли данный репозиторий в вашей системе следующим образом:

Linux Mint: необходимо осуществить переход в рамках главного меню: «Меню — Администрирование — Менеджер обновлений». После этого в рамках меню открывшегося окна менеджера обновлений следует осуществить переход: «Правка — Источники приложений». Теперь следует нажать на кнопку «Официальные репозитории» в левой части окна и обратить внимание на флажок «Портированные пакеты (backport)».

Ubuntu: в первую очередь установите менеджер пакетов Synaptic с помощью Центра приложений Ubuntu, если он еще не установлен в вашей системе. После этого нажмите на логотип Ubuntu в левом верхнем углу экрана, введите запрос «synaptic» и выберите пункт «Менеджер пакетов Synaptic» для его запуска. В рамках меню менеджера пакетов Synaptic следует осуществить переход «Настройки — Репозитории», перейти на вкладку «Обновления» в открывшемся окне и обратить внимание на флажок «Официально не поддерживаемые обновления (trusty-backports)».

Источник официально не поддерживаемых обновлений «backports» дистрибутива Ubuntu связан с меньшим количеством рисков, чем источник обновлений, не вошедших в официальный выпуск «proposed» этого же дистрибутива, так как он содержит стабильно работающее программное обеспечение. Но это программное обеспечение не было в достаточной степени протестировано на совместимость с вашей версией дистрибутива Ubuntu. Следовательно, оно может негативно повлиять на стабильность вашей системы (или ее некоторых компонентов).

Хотя данный репозиторий и активирован по умолчанию, ему присвоен низкий и безопасный приоритет. Мой совет относительно данного репозитория достаточно прост: при работе с дистрибутивом Ubuntu следует оставить его активированным, но крайне внимательно относиться к установке пакетов программного обеспечения из него.

Для проверки приоритета источника официально не поддерживаемых обновлений «Backports» вы можете воспользоваться следующей командой в терминале:

apt-cache policy | grep backports

Теперь вы можете самостоятельно убедиться в том, что приоритет репозитория «Backports» равен 100 для всех пакетов, кроме пакетов локализации (используемых в системах с локализацией). Другие репозитории (и пакеты локализаций из репозитория «Backports») по умолчанию имеют приоритет 500.

Это означает, что вам придется явным образом указывать версию портированного пакета программного обеспечения в том случае, если отличная версия данного пакета находится в одном из других репозиториев. Преимущество данной схемы заключается в том, что при наличии пакета программного обеспечения лишь в репозитории «Backports» у вас будет возможность установить его без модификации каких-либо файлов.

8.2. Репозитории «Partners» и «Independent»

Актуально для дистрибутива Ubuntu, но не для дистрибутива Linux Mint; вы можете проверить текущий статус репозиториев «Partners» и «Independent» следующим образом. В первую очередь установите менеджер пакетов Synaptic с помощью Центра приложений Ubuntu, если он еще не установлен в вашей системе. После этого нажмите на логотип Ubuntu в левом верхнем углу экрана, введите запрос «synaptic» и выберите пункт «Менеджер пакетов Synaptic» для его запуска. В рамках меню менеджера пакетов Sysnaptic следует осуществить переход «Настройки — Репозитории» и перейти на вкладку «Другое ПО» в открывшемся окне. С помощью списка на данной вкладке вы можете активировать репозиторий «Партнеры Canonical» («Partners», не активирован по умолчанию) и репозиторий «Независимое» («Independent»). Таким образом вы сможете получить доступ к стороннему программному обеспечению от компаний (партнеров), которые заключили соглашения с компанией Canonical.

Данные репозитории содержат большое количество пакетов с полезным программным обеспечением. Но эти же репозитории могут стать причиной снижения безопасности вашей системы, так как пакеты из этих репозиториев не всегда своевременно обновляются… Новые версии программного обеспечения из упомянутых репозиториев создаются силами комнаний-партнеров Canonical и независимых разрабочиков: специалисты компании Canonical ответственны лишь за упаковку программного обеспечения в пакеты. Компании-партнеры Canonical и независимые разработчики не всегда подходят к вопросам безопасности своего программного обеспечения с должной отвественностью.

Достаточно вспомнить, что в прошлом в репозитории партнеров Canonical («Partners») была размещена устаревшая и небезопасная версия Adobe Flash Player (в то время, как в обычном репозитории программ, ограниченных патентами или законами «Multiverse» была размещена обновленная версия в пакете программного обеспечения под другим именем!).

Аналогичная ситуация была и с отдельными локализованными версиями приложения Adobe Reader (которое нередко становится целью атак вредоносного программного обеспечения).

Исходя из всего вышесказанного, следует использовать упомянутые выше репозитории с осторожностью. Вы можете активировать их в своей системе, но вы не должны быть уверены в безопасности программного обеспечения, установленного из них.

9. Никогда не удаляйте какие-либо приложения, являющиеся частью стандартной поставки дистрибутива

Даже если вы не пользуетесь определенным приложением из стандартной поставки вашего дистрибутива, не удаляйте его. Причина достаточно проста: комплект стандартной поставки дистрибутива является взаимосвязанной системой, стабильность работы которой напрямую зависит от наличия используемых приложениями вспомогательных файлов.

Если вы удаляете приложение из стандартной поставки дистрибутива, вы рискуете серьезно повредить свою систему. В случае удаления части приложений этот риск значительно больше, чем в случае удаления большинства приложений, а в случае удаления другой небольшой части приложений подобного риска нет вообще. Но все-таки лучше избегать подобного риска.

Если вы желаете, вы можете удалить неиспользуемое приложение из стандартной поставки дистрибутива из главного меню системы, но не стоит удалять его из системы.

Это предупреждение относится лишь к тем приложениям, которые устанавливаются в процессе установки дистрибутива Linux Mint, Ubuntu или Fedora Workstation и являются частью его стандартной поставки. Приложения, которые вы устанавливаете самостоятельно, могут безопасно удаляться из системы.

10. Не экспериментируйте на основной машине

С высокой долей вероятности можно предположить, что не все ваши компьютеры одинаково важны для вас. Некоторые компьютеры используются для выполнения важной работы и являются «рабочими лошадками», на которых вы всегда можете положиться. Другие компьютеры являются в большей или меньшей степени «развлекательными системами», которые также нередко используются, но не так важны.

Важно относиться по-разному к компьютерам обоих упомянутых типов. Не стоит экспериментировать на компьютерах, используемых для выполнения важной работы, вне зависимости от того, насколько сильно желание испытать в работе новые версии программного обеспечения.

Проводите эксперименты только на развлекательных системах или на отдельной тестовой машине. Ведь в противном случае вы можете привести систему на машине, используемой для выполнения важной работы, в нерабочее состояние.

Лучшим решением для машин, предназначенных для выполнения важной работы, является использование лишь версий дистрибутива Ubuntu с длительным сроком поддержки. Это объясняется тем, что версии с длительным сроком поддержки являются чрезвычайно качественными и надежными. Все версии дистрибутива Linux Mint на сегодняшний день основываются на версиях дистрибутива Ubuntu с длительным сроком поддержки (начиная с серии 17), поэтому Linux Mint также подходит для таких машин.

Если вы желаете обновить версию дистрибутива Ubuntu с длительным сроком поддержки на машине, предназначенной для выполнения важной работы, вам стоит делать это только после выпуска первой подверсии данной версии дистрибутива (своего рода «сервис-пака») или новой версии с длительным сроком поддержки.

Как говорилось ранее, лучшей практикой является разделение парка компьютеров на три категории: рабочие лошадки, развлекательные системы и тестовые машины.

  • На рабочие лошадки рекомендуется устанавливать лишь версии дистрибутива Ubuntu с длительным сроком поддержки, а также все новые версии дистрибутива Linux Mint (начиная с версии Linux Mint 17, все текущие и будущие версии дистрибутива Linux Mint будут основываться на версиях дистрибутива Ubuntu с длительным сроком поддержки).
  • На развлекательные системы рекомендуется устанавливать последние стабильные версии дистрибутива Ubuntu через каждые шесть месяцев.
  • На тестовые машины можно устанавливать любые альфа-, бета- и разрабатываемые версии дистрибутивов Ubuntu и Linux Mint для самых смелых экспериментов и поиска ошибок.

Хотите ознакомиться с дополнительными советами?

Хотите узнать о других настройках и приемах работы с дистрибутивом Linux Mint, Ubuntu или Fedora Workstation? На данном веб-сайте размещено большое количество подобных материалов.